What default Splunk role can use the Log Event alert action?
APower
BUser
Ccan_delete
DAdmin
What qualifies a report for acceleration?
AFewer than 100k events in search results, with transforming commands used in the search string.
BMore than 100k events in search results, with only a search command in the search string.
CMore than 100k events in the search results, with a search and transforming command used in the search string.
DFewer than 100k events in search results, with only a search and transaction command used in the search string.
If a nested macro expands to a search string that begins with a generating command, what additional syntax is needed?
ADouble tick marks around the nested macro.
BA comma before the nested macro.
CSquare brackets around the nested macro.
DA pipe character before the nested macro.
Which of the following are potential string results returned by the typeof function?
ATrue, False, Unknown
BNumber, String, Bool
CNumber, String, Null
DField, Value, Lookup
What capability does a power user need to create a Log Event alert action?
Aedit_search_server
Bedit_udp
Cedit_tcp
Dedit_alerts
Which of the following statements is accurate regarding the append command?
AIt is used with a subsearch and only accesses real-time searches.
BIt is used with a subsearch and only accesses historical data.
CIt cannot be used with a subsearch and only accesses historical data.
DIt cannot be used with a subsearch and only accesses real-time searches.
When and where do search debug messages appear to help with troubleshooting views?
AIn the Dashboard Editor, while the search is running.
BIn the Search Job Inspector, after the search completes.
CIn the Search Job Inspector, while the search is running.
DIn the Dashboard Editor, after the search completes.
How can the Inspect button be disabled on a dashboard panel?
ASet inspect.link.disabled to 1
BSet link.inspect.visible to 0
CSet link.inspect.Search.visible to 0
DSet link.search.disabled to 1
Assuming a standard time zone across the environment, what syntax will always return events from between 2:00am and 5:00am?
Adate hour>=2 AND date_hour<5
Bearliest==2h@h AND latests-5h@h
Ctime_hour>=2 AND time_hour>=5
Dearliest-2h@h AND latest=5h@h
Which function of the stats command creates a multivalue entry?
Amvecombine
Beval
Cmakemv
Dlist
A report named "Linux logins" populates a summary index with the search string sourcetype=linux secure | sitop src ip user. Which of the following correctly searches against the summary index for this data?
Aindex=summary sourcetype="linux_secure" | top src_ip user
Bindex=summary search name="Linux logins" | top src ip user
Cindex=summary search_name="Linux logins" | stats count by src_ip user
Dindex=summary sourcetype="linux secure" | stats count by src_ip user
What is returned when Splunk finds fewer than the minimum matches for each lookup value?
AThe default value NULL until the minimum match threshold is reached.
BThe default match value until the minimum match threshold is reached.
CThe first match unless the time_field attribute is specified.
DOnly the first match.
What arguments are required when using the spath command?
Ainput, output, index
Binput, output, path
CNo arguments are required.
Dfield, host, source
Which statement about the coalesce function is accurate?
AIt can take only a single argument.
BIt can take a maximum of two arguments.
CIt can be used to create a new field in the results set.
DIt can return null or non-null values.
Which field is required for an event annotation?
Aannotation category
B_time
Ceventtype
Dannotation label
How is a multivalue field created from product="a,b,c,d"?
A...| makemv delim(product, ",")
B...| eval mvexpand(makemv(product, ","))
C...| mvexpand product
D...| makemv delim="," product
What does the query | makeresults generate?
AA timestamp
BA results field
CAn error message
DThe results of the previously run search
Which of the following functions' primary purpose is to convert epoch time to a string format?
Atostring
Bstrptime
Ctonumber
Dstrftime
Which element attribute is required for event annotation?
A <search type="event_annotation">
B <search style="annotation">
C <search type=$annotation$>
D <search type="annotation">
Which predefined drilldown token passes a clicked value from a table row?
A$rowclick.<fieldname>$
B$tableclick.<fieldname>$
C$row.<fieldname>$
D$table.<fieldname>$
Which of the following would exclude all entries contained in the lookup file baditems.csv from search results?
ANOT [inputlookup baditems.csv]
BNOT (lookup baditems.csv OUTPUT item)
CWHERE item NOT IN (baditems.csv)
D[NOT input.lookup baditems.csv]
Which of the following best describes the process for tokenizing event data?
AThe event data is broken up by values in the punct field.
BThe event data is broken up by major breakers and then broken up further by minor breakers.
CThe event data is broken up by a series of user-defined regex patterns.
DThe event data has all punctuation stripped out and is then space delimited.
Which of the following is valid syntax for the split function?
A| eval split phoneNumber by “-“ as areaCode
B| eval areaCodes - split(phoneNumber, “-“)
C| eval phoneNumber split(“-“, 3, areaCodes)
D| eval split(phoneNumber, “-“, areaCodes)
When would a distributable streaming command be executed on an indexer?
AIf any of the preceding search commands are executed on the search head.
BIf all preceding search commands are executed on the indexer, and a streamstats command is used.
CIf all preceding search commands are executed on the indexer.
DIf some of the preceding search commands are executed on the indexer, and a timechart command is used.
Where can wildcards be used in the tstats command?