A secure function returns data received through an inbound share.
What occurs if a Data Engineer attempts to grant USAGE privileges on this function to an outbound share?
Snowflake does not permit a database or database object created from an inbound share to be reshared through another share. Attempting to grant USAGE on the secure function to an outbound share returns an error, even though secure UDFs are generally shareable objects.
Community Discussion