QuestionQ33

Manage Building an NKP Cluster

Refer to the exhibit.

Question Image

An administrator is provisioning an NKP cluster. After the VM creation task completes, the error shown in the exhibit occurs.

What could be the cause?

Explanation

Registry connectivity is required for cluster nodes to pull the CAPI controller images. If the VM cannot reach the registry, the capp-controller-manager deployment cannot become ready, causing the CAPI upgrade to time out. NKP documentation also identifies private-registry image-pull failures as a cause of deployment failures.

Learn more

Community Discussion

No comments yet. Be the first to start the discussion!